Div hover probléma

Div hover probléma
2009-01-21T00:45:25+01:00
2009-01-21T09:28:01+01:00
2022-11-12T07:55:34+01:00
wintercounter
Sziasztok!

A problémám az lenne, hogy vannak a következő kódjaim. Az egész lényege az, hogy egy kép a background, és amikor rámegyek az egérrel feljebb ugrik. Ezzel nincs is gond, megy is rendesen. A probléma az, hogy van egy hover menü is. Ezzel sem lenne gond, mert megjelenik, amikor rámegyek a képre. Inkább az a gond, a nav_buttons1_sub class-ba betölti magát a gombot is, újra és újra a linkek helyére.

Nem könnyű így elmondani, úgyhogy itt egy kép, ezeket a nyilakat akarom eltüntetni onnan.

Kép1

HTML:
<div class="nav_buttons1"> <a href="#"><img width="45" class="tip" height="39" src="/themes/site_themes/mu2/cp/clear.gif"/></a> <div class="nav_buttons1_sub"> <a href="#">Link1</a><br> <a href="#">Link2</a><br> <a href="#">Link3</a><br> <a href="#">Link4</a><br> <a href="#">Link5</a> </div> </div>

CSS:
.nav_buttons1 {position:absolute; left: 140px; top: 27px; z-index: 700; display: block} .nav_buttons1 a { background: transparent url('/themes/site_themes/**/nav/nav_frontpage.png') no-repeat; display: block; width: 45px; height: 32px; } .nav_buttons1 a:hover { background: transparent url('/themes/site_themes/**/nav/nav_frontpage.png') no-repeat; width: 45px; height: 39px; position:absolute; top: -5px; } .nav_buttons1 .nav_buttons1_sub { display: none;} .nav_buttons1:hover .nav_buttons1_sub { display: block; width: 300px; background: #000;}
Mutasd a teljes hozzászólást!
Meghatároztad a
.nav_buttons1 a { background: transparent url('/themes/site_themes/**/nav/nav_frontpage.png') no-repeat; display: block; width: 45px; height: 32px; }
tulajdonságait.
Tudomásul is vette, az összes linknek az a kép lesz a háttere.
Ha a belső divben levőknek nem akarod, tegyél különbséget id, vagy class alkalmazásával.

megj. ugye a /**/ csak itt jelenik meg a kép elérési útjában
Mutasd a teljes hozzászólást!

Tetszett amit olvastál? Szeretnél a jövőben is értesülni a hasonló érdekességekről?
abcd