VS 2005 vs. .NET 2003 vs VB6

VS 2005 vs. .NET 2003 vs VB6
2007-12-05T07:03:09+01:00
2007-12-05T15:30:10+01:00
2022-11-06T22:40:39+01:00
Vikcica
Üdv Srácok,

bocs, hogyha esetleg a nem megfelelő helyen járok a talán nem megfelelő problémámmal, de nem tudom, hol is kellene ezt konkrétan megtudakolnom, ezért bátorkodtam az "oroszlánbarlangban" feltenni kérdésemet, ami gyakorlatilag végtelenül egyszerűnek is tünhet :

egy gépre kellene telepitenem Visual Studio 2005-öt, .NET 2003-at illetve Visual Basic 6-ot, a szükséges SP-vel együtt.

A kérdés adódik : fel lehet-e telepiteni ezt a 3 rendszert egy gépre, ha igen, akkor van-e valami kitétel, amire oda kell figyelnem, ha nem, akkor mit csináljak?

Előre is köszi, és mégegyszer bocs, ha nem jó helyen keresgélek.

Vica
Mutasd a teljes hozzászólást!
A 2k8-ban az a jó hogy be lehet állítani hogy .NET 2.0, 3.0 vagy 3.5-re akarsz-e fejleszteni vele. Én a béta2-t használtam eddig 2.0-ás project esetén, windows.forms esetén nem volt gond, asp.net -nél az ajax-szal volt egy kisebb szívás de az lehetett attól is hogy béta (vagy én voltam hülye). De az ASP.NET-et amúgy is áttettem 3.5-re, az end-júzernél úgyis dedikált szerver van, azon pedig az van amit mondok hogy legyen.
Viszont egy dolog van: a 2k5->2k8 egyirányú utca, új projectformátuma van amit szépen átkonvertál de a 2k5 mégegyszer már nem nyitja meg.
Mutasd a teljes hozzászólást!

  • A 2K3 és a 2K5 közt lehetnek konfliktusok bár talán elvben megoldható. A VB6-tal nem hiszem. Amúgy az aktuális verzió 2k8.
    Mutasd a teljes hozzászólást!
  • Szió,

    a VB6-ot közben felraktam SP6-al együtt...

    A 2k8-at érdemes felrakni, n tesztelted még esetleg?

    Annyira új, hogy még nem volt időm vele érdemben foglalkozni

    Igazából hirtelen annyi lérdekelne, hogy a 2k5-ben irt alkalmazások szerkeszthetőek-e vele, vagyis nincs-e verzió akadás?

    Köszi.,

    Vica
    Mutasd a teljes hozzászólást!
  • A 2k8-ban az a jó hogy be lehet állítani hogy .NET 2.0, 3.0 vagy 3.5-re akarsz-e fejleszteni vele. Én a béta2-t használtam eddig 2.0-ás project esetén, windows.forms esetén nem volt gond, asp.net -nél az ajax-szal volt egy kisebb szívás de az lehetett attól is hogy béta (vagy én voltam hülye). De az ASP.NET-et amúgy is áttettem 3.5-re, az end-júzernél úgyis dedikált szerver van, azon pedig az van amit mondok hogy legyen.
    Viszont egy dolog van: a 2k5->2k8 egyirányú utca, új projectformátuma van amit szépen átkonvertál de a 2k5 mégegyszer már nem nyitja meg.
    Mutasd a teljes hozzászólást!
  • Szia,

    hát, köszi a kielégitő felvilágositást.

    Én igazából mindhárom "platform" Visual Basic-részét fogom használni, tehát ajax, asp, stb...kizárva...legalábbis egyenlőre.

    Arra jutottam, hogy felrakom mindhármat, ahogy irtam is, a Visual Basic 6 már fenn van, most megy a Visual Studio 2005, utána meg megy a .NET 2003....lesz ami lesz

    Köszönöm a segitséget.

    Vica

    ps. a pont a Tied.
    Mutasd a teljes hozzászólást!
  • Kösz. Ami azt illeti hacsak nincs valami nagy 2k3-mas projected akkor én nem nagyon erőltetném a 2k3 dolgot. A VB6-nak még van némi létjogosultsága a win32 API miatt (ha sok az olyan ügyfeled aki 5 éve nem vett új gépet), de a 2k3-nak és az 1.1-es .NET-nek szvsz már nem nagyon.
    Mutasd a teljes hozzászólást!
  • Kissé megkésve:
    Nálam mindhárom környezet fent van, mert nem éri meg a régebbi projecteket átkonvertálni egy pici változtatásért, az újakat meg az aktuális verzióval kezdem el. Nem futottam bele semmi problémába.

    Azonban egyetértek LC-vel: a fenti esetet leszámítva tök felesleges 3 különböző verzió. Esetleg a VB6 (ha olyan spec dolog van amihez nem jó a .NET) és a legfrisebb .NET-es (2k5 vagy manapság inkább 2k8) bőven elég.
    Mutasd a teljes hozzászólást!
  • Szia stl,

    Neked is köszi a hozzászólást.

    Lehet, hogy most fogok egy oltári nagy butaságot kérdezni, de kénytelen vagyok, és még szőke sem

    Szóval, a Visual Studio 2005, és a .NET 2003 az teljesen más fejlesztőkörnyezet, ugye?

    Azért nem világos, mert egy biztosan .NET 2003 VB-ben irt alkalmazást nem tudok megnyitni a Visual Studio 2005-el...

    Vagy valami nagyon el van cseszve, vagy én vagyok ennyire béna, nem tudom....

    Szerinted?

    Vica
    Mutasd a teljes hozzászólást!
  • .NET 2003 = Visual Studio 2003
    VS2k3-al .NET framework 1.1-el kompatibilis, VS 2k5-el pedig 2.0 kompatibilis alkalmazásokat tudsz készíteni.

    Elméletileg 2k5 tud konvertálni 2k3-as projecteket (több-kevesebb sikerrel), de megnyitni sajna nem lehet.
    Mutasd a teljes hozzászólást!
  • Azért nem világos, mert egy biztosan .NET 2003 VB-ben irt alkalmazást nem tudok megnyitni a Visual Studio 2005-el...


    stl-hez csatlakozom, magam is tapasztaltam, hopgy 2K3-as progimat, ha a VS 2K5 felismerte, akkor felajánlja a konvertálást, annak eredményét már meg tudja nyitni, de az eredetit nem.
    Mutasd a teljes hozzászólást!
Tetszett amit olvastál? Szeretnél a jövőben is értesülni a hasonló érdekességekről?
abcd