Firefoxban, Tor-ban nem működik a menü a weblapon
2022-06-09T10:32:41+02:00
2022-06-17T21:33:32+02:00
2022-08-12T09:35:30+02:00
Juhász Péter
Készítettem egy weboldalt html-ben. Firefoxban és Torban nem működik a menü. Egyik gépemen megjelenik, de nem lehet a gombokra kattintani, másik gépen meg sem jelenik a menü. Más böngészőkben Chrome, IE, működik normálisan. Sehogy nem találom a probléma forrását. Remélem, tudtok segíteni! A szóban forgó weboldal: www.tisztairoda.hu
Előre is köszönöm!
Mutasd a teljes hozzászólást!
1725 sor header -  clip-path: url(#svgPath); kapcsold ki, nem igazán csinál semmit
Mutasd a teljes hozzászólást!

  • Nem megy az Chrome-ban sem:

    GET https://tisztairoda.hu/script.js [HTTP/2 404 Not Found 27ms]
    Mutasd a teljes hozzászólást!
  • Köszi, megnéztem. Ami abban a javascriptben van, nem használja az oldalon. Töröltem az id hivatkozását a kapcsolat menüpont alatt. Teszteltem, úgy sem működik, továbbá inaktívvá tettem a js fájlt a kapcsolat menüpont alatt. Ezáltal most nem hívja meg a www.tisztairoda.hu/kapcsolat.html azt a javascriptet.

    <!-- partial 
      <script  src="./script.js"></script-->


    De így is tudok kattintgatni a gombokra chrome-ban, de Firefoxban nem.
    Mutasd a teljes hozzászólást!
  • Uhhh, hát ekkora nagy katyvaszban nem is csoda... De konkrétan ha a css 247. sora környékén a .hero-image z-indexe nem lenne -10, akkor már lenne lehulló menüd is :)
    Egyébként nem is értem ezt a sok z-indexet, mert nagyjából semmit nem csinálnak, elvégre a html-ben normális sorrend a megjelenés sorrendje is egyben, és nem igazán látok olyan elemet, ami a html-ben előbb lenne definiálva és takarva lenne egy később definiálttal.
    De maga a teljes html és css is 50-60% fölösleges sorral van tele, valaki gondolom fogott egy régi oldalt és megpróbálta átszabni, ezért egy csomó teljesen fölösleges komment van a html részen, css-ben pedig nagyon sok újradefiniálás, ami szintén csak a fájl méretét növeli.
    Mutasd a teljes hozzászólást!
  • Abszolút igazad van a katyvasszal kapcsolatban. Egy jól SEO-zott oldalt, amit nulláról írtam,azt adoptáltam. Meg tettem bele codepen.io-ról dolgokat, amiket aztán kivettem, s maradtak benne dolgok...

    Viszont azt a szóban forgó z-indexet már mostanában tesztként tettem be, eredetileg nem volt ott és úgy sem működött. Most átállítottam z-index:100-ra, de így sem megy. 

    Talán az egy jó kiindulópont szerintem, hogy akármilyen is a katyvasz, meg a z-indexek sokasága, mégis működik más böngészőkben, de Firefoxban nem. Szóval, ha z-index, vagy egyéb ilyen probléma lenne, akkor Chrome-ban sem kellene működnie.

    Köszi, hogy ránéztél!
    Mutasd a teljes hozzászólást!
  • 1725 sor header -  clip-path: url(#svgPath); kapcsold ki, nem igazán csinál semmit
    Mutasd a teljes hozzászólást!
  • Köszönöm szépen!

    Sikerült, kikapcsoltam az egészet, egyedül csak a color:white-t hagytam meg. :D S működik firefoxban is a menü. Örök hála! :)
    Mutasd a teljes hozzászólást!
abcd