Miért nem tudok egy összesített értéket számként kifejezni egy Excel cellában?

Miért nem tudok egy összesített értéket számként kifejezni egy Excel cellában?
2021-03-16T17:23:04+01:00
2021-03-17T10:21:12+01:00
2022-10-15T21:16:39+02:00
rudolphe
Üdvözletem! Értékek átadásával szeretném vezérelni a makrók hívását egy Excel dokumentumban!
A problémát az okozza, hogy amíg számmal kifejezhető, nullánál nagyobb érték van az összegzett cellák eredményei között, addig teljesülnek a működés feltételei, de amikor nincs számmal kifejezhető érték, akkor "#SZÁM!" felirat jelenik meg a kérdéses cellában és ez ellehetetlenít a kitűzött célom megvalósításában, - lényegében el sem indul a makró, amíg ezt a hibát ki nem küszöbölöm. Az összesített érték DARABTELI(); KICSI(); HA(); VAGY(); ill. NAGY() függvények által kiszámolt cellák összesített eredményeiből nyerem ki és az alábbi függvénnyel oldottam meg a fő összesítést:

=HA(NAGY($BA$94:$BJ$101;$U$1)<>0;NAGY($BA$94:$BJ$101;$U$1);"")

Próbáltam a "" helyett "0"-t, próbálkoztam abszolút értékkel, - magától értetődő, hogy mielőtt rászántam magam a segítség kérésére, - öt napon keresztül - végig böngésztem egyesével a - jelenleg - 245 oldalon szerepeltetett megoldásokat, azonban egyikben sem ismertem rá olyan megoldásra, amely a problémámra megoldást jelentene.

Megoldható képlet módosítással, hogy numerikus értéket írjon ki a kérdéses cella?
Az építő jellegű válaszokat előre is köszönöm!
Mutasd a teljes hozzászólást!
Szia!

Nem tudom, hogy segít-e rajtad, de ha a HAHIBA(érték, érték hiba esetén) fv-t használod, akkor hiba esetére a cella eredménye nulla lesz és nem #SZÁM hibaérték.
Próbáld ki ezt:
=HAHIBA(HA(NAGY($BA$94:$BJ$101;$U$1)<>0;NAGY($BA$94:$BJ$101;$U$1);"");0)
De vigyázz ez nem várt eredményre is vezethet, ha mondjuk mégis csak jobb lenne a hiba és azt kellene kezelned.

Nem tudom mi okozhatja a hibát.
A súgóból:
NAGY(tömb; k)
Ha a tömb üres, akkor a NAGY a #SZÁM! hibaértéket adja eredményül.
Ha k ≤ 0 vagy k nagyobb az adatpontok számánál, akkor a NAGY eredménye a #SZÁM! hibaérték lesz.
Nem fordulhat elő a kettő közül valamelyik?
Mutasd a teljes hozzászólást!

  • Szia!

    szmolkalaszlo megoldása a legegyszerűbb.
    Esetleg a makróból is le tudod kezelni a hibás cellát, ha a HAHIBA függvény által visszaadott érték be tud zavarni. (Vagy adhatsz neki olyan visszatérési értéket, ami a táblában biztos nem fordulhat elő, pl, mint írtad 0-nál nagyobb szám, akkor a -1 nem fordulhat elő, vagy "hiba" felirat, amit simán tudsz vizsgálni makróból.)
    Mutasd a teljes hozzászólást!
  • Üdvözletem a Válaszolóknak - és köszönöm szépen a válaszokat!

    Szmolkalaszlo válasza tökéletesen orvosolja a problémámat, - tisztelettel megköszönöm a segítséget és az általa adott magyarázattal is előrébb jutottam!

    A Pados felhasználó néven beküldött válasz is segített azon a szinten, hogy részben megvilágosított, - mely szemlélet szerint nem csak a képletek által járható a megoldás.

    Én ezt a választ találtam a tibuD-től itt a Pados által említett tartalommal, ám én ehhez - sajnos - olyan szinten buta vagyok, mint a nagyon. - Gőzöm nincs arról, hogy a makrómon belül mit, mire kellene cserélnem, szerkesztenem a siker érdekében.

    Tisztelettel megköszönöm a segítségeteket!
    Mutasd a teljes hozzászólást!
  • Szmolkalaszlonak még visszajelzés, - mivel elfelejtettem:

    A második eset állt fenn!
    Nem volt numerikus érték a vizsgált elemek között, mert elfogytak ezek az értékek a felhasználásukkal egy időben.

    Köszönettel!
    Mutasd a teljes hozzászólást!
Tetszett amit olvastál? Szeretnél a jövőben is értesülni a hasonló érdekességekről?
abcd