Régebbi androidra való fejlesztés
2020-01-27T13:53:35+01:00
2020-01-28T07:58:05+01:00
2022-08-11T17:41:48+02:00
kispifta
Sziasztok!

A következő problémába futottam bele. Adott VS 2019 Pro + egy androidos eszköz amin KitKat rendszer fut (4.4). Az eszközt nem lehet frissíteni. A problémám ott van hogy ha a studióban kiválasztom a 4.4-es android verziót, akkor error hegyek. Próbáltam sima Xamarin projectet+ Xamarin.Forms projectet is, de nem sok sikerrel. A Xamarin.Forms kiírja hogy neki nagyobb verziójú kellene min 8.1-es. A sima Xamarinos pedig a következő üzenettel fogad, amikor átváltom a TargetFramework-t:

Your project does not reference "MonoAndroid,Version=v4.4" framework. Add a reference to "MonoAndroid,Version=v4.4" in the "TargetFrameworks" property of your project file and then re-run NuGet restore.    App1

Nos nekem nincs ilyen verzióm belőle. Próbáltam a NuGet-ben az update packages, de nem hozott sok sikert.

Valaki tudna segíteni hogy mégis hogyan kellene megoldani?
Vagy ha reménytelen, akkor van valami infótok, hogy mennyire gáz ha 8.1-re megcsinálom az app-ot, beállítom a minimum framework-t 4.4? Gondolok itt a kompatibilitási gondokra.
Vagy inkább használjak android studiot? ott meg lehet oldani ezt?

Előre is köszi!
Mutasd a teljes hozzászólást!
Android project jobb click, Properties, Android Manifest fül, Minumum Android Version. Napi szinten fejlesztek vele a 6-os droiddal megvert telefonomra.
Mutasd a teljes hozzászólást!

abcd