Miért nem telepíti az npm a csomag függőségeit?
2017-08-19T16:34:57+02:00
2017-08-19T22:34:26+02:00
2022-08-18T18:25:35+02:00
adrian1928
Erre a parancsra:
npm install bootstrap@4.0.0-beta
Ezt az üzenetet kaptam:
npm notice created a lockfile as package-lock.json. You should commit this file.
npm WARN bootstrap@4.0.0-beta requires a peer of jquery@>=3.0.0 but none was installed.
npm WARN bootstrap@4.0.0-beta requires a peer of popper.js@^1.11.0 but none was installed.
npm WARN malom@1.0.0 No description
npm WARN malom@1.0.0 No repository field.

+ bootstrap@4.0.0-beta
added 1 package in 1.765s

Miért nem telepítette fel automatikusan azt a két package-et?
Mutasd a teljes hozzászólást!
Peer Dependencies

npm3 óta nem fogja neked automatikusan feltelepíteni. Megnézed neked melyik a megfelelő jquery verzió és azt feltelepíted. npm install ki fogja írni melyik peer dependency nincs még feltelepítve.

Ennek az az oka, hogy a jquery pluginok más más verzióval működnek, neked kell kitalálni melyik verzióval működik az összes amit használni akarsz.
Mutasd a teljes hozzászólást!

abcd