Microsoft 2008 C + + Runtime
2011-06-29T07:16:31+02:00
2011-06-29T15:30:28+02:00
2022-08-15T14:30:33+02:00
Mumus
Sziasztok.
Hasonló kérdést tettem már fel , de nemjutottam túl rajta.

vs 2008 -at keztem, ami net 3.5 használ.
Csináltam egy egyszerű ablakot , megnyilt semmi probléma. De átvittem egy másik gépre és kiírta hogy nem futtatható.
Ha a fordított programot átviszem egy másik gépre , akkor mien függőségei vannak ? Mit kell feltenni a gépre hogy menjen ?

Hogy van fordítva a program vagy esetleg mivel hogy csak Microsoft 2008 C + + Runtime. MSVC 2008 32bit -et kérje ?

Előre is köszi.
Mutasd a teljes hozzászólást!
Hasonló kérdést tettem már fel , de nemjutottam túl rajta.

Hol, mikor?
vs 2008 -at keztem, ami net 3.5 használ.

A másik gépen van .Net 3.5?
Mit kell feltenni a gépre hogy menjen ?

Adj a project-edhez egy setup project-et, kreálj egy solution-t.
Lesz egy akarmi.msi-d, azt vidd át a másik gépre.
Ha ez kevés, akkor az akarmi.msi alatt lesz még egy setup.exe ez már mindent felpakol a gépedre, ha van internet elérési lehetőség az adott gépen.
Mutasd a teljes hozzászólást!

  • huhh, projketbeállitasoknal van vmi "MultiThreaded DLL", azt próbáld meg áttenni "MultiThreaded"re, ( illetve "MultiThreaded Debug DLL"t -> "MultiThreaded Debug"ra )
    Mutasd a teljes hozzászólást!
  • Hasonló kérdést tettem már fel , de nemjutottam túl rajta.

    Hol, mikor?
    vs 2008 -at keztem, ami net 3.5 használ.

    A másik gépen van .Net 3.5?
    Mit kell feltenni a gépre hogy menjen ?

    Adj a project-edhez egy setup project-et, kreálj egy solution-t.
    Lesz egy akarmi.msi-d, azt vidd át a másik gépre.
    Ha ez kevés, akkor az akarmi.msi alatt lesz még egy setup.exe ez már mindent felpakol a gépedre, ha van internet elérési lehetőség az adott gépen.
    Mutasd a teljes hozzászólást!
  • Próbáld meg release-ben fordítani, hátha akkor megy.
    Nem írtad, hogy miért nem futtatható, ezért ha valami dll hiányzik szükséges lehet egy "Redistributable Package" (arra, ami a te gépeden is van), amit az $ms oldaláról le lehet tölteni.
    (Ez így csak találgatás.)
    Ill segíthet az is, ha (IWolf88 által mondott) Runtime Library-t release-ben /MT-re, debugban /MTd-re állítod.
    Mutasd a teljes hozzászólást!
  • Még nem zárom le a témát , virtualizálok egy xp-t és avval probálom meg otthon.
    Ide melóhelyre hozom be , feltettem a net 3.5 -öt és nem ment.
    De amit ajánlotok kiprobálom :)
    Mutasd a teljes hozzászólást!
  • Ha csak a .Net 3.5 hiányzott, akkor felesleges a többit próbálgatni szerintem. És mivel megoldódott a problémád, a megoldónak/megoldást segítőnek (asszem Riha) jogosan járna a petty.
    Mutasd a teljes hozzászólást!
Tetszett amit olvastál? Szeretnél a jövőben is értesülni a hasonló érdekességekről?
abcd