Debian + Apache 1.3 + Python
2008-11-12T16:02:42+01:00
2008-11-18T17:32:31+01:00
2022-06-29T07:30:34+02:00
  • Szia,

    a "http://xxx.hu/test.py " nevű állomány
    gondolom egy CGI-script. Amennyiben igen, akkor
    talán-tán a script nem megfelelő könyvtárban
    van. Amennyiben a ha CGI-script-et más könyvtárból
    szeretnéd indítani, akkor a httpd.conf -ot módosítani kell,
    bár nem érdemes ezt variálni.
    Egyébként alapértelmezés szerint a CGI scripte-ek helye
    "/srv/www/cgi-bin"(SUSE) esetleg régi Linux-ok esetén
    "/var/www/cgi-bin".
    Továbbá másik lehetőség az, hogy netán a "test.py"
    scriptnek nem adtál futtatási jogot(chmod +x valami.py).

    Minden esetre az apache 1.3 eléggé régi, próbáld meg
    apache2-t telepíteni, és 2.5 -ös Python-t,
    saját tapasztalatom szerint Apache2 és a Python 2.5
    gond nélkül működik.
    Mutasd a teljes hozzászólást!
  • Helló!

    Szinte mndent megpróbáltam már, de nem megy!!!
    Bármit csinálok bármit írok az apache httpd.conf fájlba nem megy.
    beírom a http://xxx.hu/test.py a böngészőbe és csak le akarja tölteni a fájlt. Segítsetek pls.
    Mutasd a teljes hozzászólást!
  • Szia,

    ha csak az apache konfigurálással van problémád,
    talán ezen a tutorial linken találsz segítséget :
    Apache Configuration
    Mutasd a teljes hozzászólást!
  • Halika!

    Ezzel most arra célzol hogy másképpen kell bekonfigolni apache 1.3 alatt ezt a jó kis pythont mint apache 2 alatt?

    Ha igen akkor köszike máris nézek valami másik doksit neten. Thx

    Azért ha mégsem akkor még segíthetnétek :D
    Mutasd a teljes hozzászólást!
  • a tutorial címe: "Embedding Python In Apache2..."

    neked meg apache1.3-ad van.
    Mutasd a teljes hozzászólást!
  • Helló!

    A segítségeteket szeretném kérni! Olyan problémába ütköztem szeretnék Python -t futtatni az Apache webszerveremen.
    Ezen link-en található instrukciók alapján jártam el. És mégsem megy a dolog ha böngészőbe beírom a .py fájlom elérési útját akkor csak mentés opció jelenik meg.

    A szerveremen fent van :
    -Debian Etch
    -Apache 1.3
    -libapache-mod-python
    -Python 2.4

    Ahhoz hogy weben keresztül tudjak futtatni Python -t mi kellhet még, kell e még valami?

    Apache konfigfájlba szerintem jó helyre írtam be azt a néhány sort.Nem tudom mi baja lehet.

    Help me! Plz!!!!
    Mutasd a teljes hozzászólást!
abcd