PHP upgrade Debian-on
2018-06-20T18:27:58+02:00
2018-06-25T10:05:31+02:00
2022-07-21T05:13:37+02:00
  • Koszi. Kozben php7 upgrade lesz belole, de a gond az volt, hogy akarmilyen repot adtam hozza, nem talalta az adott verzioju (5.35, 5.36) php-t ezekre a commandokra:

    sudo apt install php=5.6.35

    (Illetve php5=...)

    Ezt megmagyarazza hogy nem tamogatja a Jessie (8.1) hivatalosan.
    Mutasd a teljes hozzászólást!
  • Ha mégis úgy döntesz, hogy beírod ide, hogy mit próbáltál, és milyen hibaüzenetet kaptál, esetleg tudok segíteni.
    Mutasd a teljes hozzászólást!
  • Koszi a reszletes valaszt. Ezek szerint nem (csak) en vagyok bena ehhez. Egyetertek, a legjobb megoldas a php 7-re upgradeles, ezert ezt fogjuk tenni.
    Mutasd a teljes hozzászólást!
  • Nemigen lesz mindennapi rutin senkinek, mert ahogy én látom, a debian már áttért a 7-es php-ra, tehát nem nagyon fogják már az új 5-ös verziókat csomagolni. 

    A) Igazából neked is azt tudom javasolni, hogy állj át a 7-re, mert még ha ezt az 5-öst most sikerül is becsomagolnod, az idő múlásával ez egyre nehezebb lesz.

    B) Ezen a weboldalon mintha lennének 36-os deb-ek:

    Index of /pool/all/p/php5/

    Nyilván nem lesz olyan minőségű, mint a hivatalos csomag, de akár működhet is.

    C) Megteheted azt, hogy hagyod a csomagolást, simán letöltöd a forrást a php weboldalról, lefordítod egy külön könyvtárba, aztán symlink-ekkel hozzákötöd a rendszeredhez. Itt a debian-specifikus dolgokról neked kell gondoskodnod.

    D) Van egy ún. checkinstall csomag a debianban. Elvileg ezzel fordítás után gyárthatsz deb csomagot, amit installálhatsz/deinstallálhatsz. A debian specifikus dolgokról neked kell gondoskodnod.

    E) Elvileg azt is megteheted, hogy a kibontod a 33-as debian forráscsomagot, a kibontott forrásba beleírod a számodra fontos különbségeket a 33 és 36 között, aztán dpkg-buildpackage-el lefordítod. Itt viszont annyi minden közbejöhet, hogy részleteket inkább nem is írok.
    Mutasd a teljes hozzászólást!
  • Sziasztok,


    miutan 3 oraja ezzel kuzdok, ugy dontottem inkabb kiadom valakinek aki ert is hozza. Van egy Debian Jessie Linux server (Linode-on fut), amin 5.6.33-as PHP fut.

    A baj az, hogy van egy ilyen security issue, ami miatt upgradelni szeretnem, de egy kompatibilis verziora, pl 5.6.35-re.
    CVE-2018-7584 : In PHP through 5.6.33, 7.0.x before 7.0.28, 7.1.x through 7.1.14, and 7.2.x through



    Keresek valakit, aki - nem ingyen - el tudja magyarazni, hogy ezt hogyan kellene megcsinalni, olyat akinek ez mindennapi rutin.

    (Kommenteket hogy miert nincs dedikalt ember erre a cegben nem kernek:)
    Mutasd a teljes hozzászólást!
Tetszett amit olvastál? Szeretnél a jövőben is értesülni a hasonló érdekességekről?
abcd