A C++ következő frissítésének minden újdonságát támogatja az LLVM 3.4
2014-01-13T09:20:24+01:00
2014-01-13T14:08:41+01:00
2022-07-23T01:32:35+02:00
  • Hö, ne tudd meg, mit kerestem, hogy miért nem megy? Ezek szerint ha lefordítom az SVN-en lévő verziót, akkor fog tudni működni vindózon 4.8.1-gyel. Thx.

    Van itt olyan, aki próbálta is? Tuti megy?

    Más: melyik ide a legjobb clanghoz? (Vagyis támogatja a C++1y szintaxist.) Nem sok időm volt próbálgatni, de a CodeLite egész jónak tűnik. (Nem muszáj vindózosnak lenni, az egyik SSD-men Ubuntu van fent, azon is tudok dolgozni.)

    Mivel a hobbi projektem core része csak Boost és OpenCL függőségű, ezért MSVC-ről clangra szeretnék váltani, mert unom már, hogy az MS van a legnagyobb hanggal a C++ reneszánszával meg a rendezvényeivel, közben a fordítójuk meg egy pusztulativadék. Kb. úgy kell elképzelni, mint az IE8-at a többi browserhez képest, csak nincs mellette IE 9,10 meg 11.
    Mutasd a teljes hozzászólást!
  • Mutasd a teljes hozzászólást!
  • Sikerült ezt már valakinek vindózon feléleszteni? Próbáltam MinGW 4.8.1 libekkel, fordul is, de az STL hívások segfaultolnak. A hozzá adott standard libeket meg nem volt erőm lefordítani, mert a makefile vindózon esélytelen.

    Ubuntun ofkorsz g++ 4.8.1-gyel simán megy.
    Mutasd a teljes hozzászólást!
abcd