J2ME NetBeans (mobil programozás)
2013-10-21T16:48:39+02:00
2013-10-24T21:17:29+02:00
2022-07-19T01:27:34+02:00
  • Több lehetőség is van, hogy miért jön elő ez a probléma. A Nokia dev fórumon azt írják - és első körben a hibaüzenetből is ez jön le - hogy nincs jól konfigurálva a classpath, azaz nem találja meg a jdk telepítési helyét. Ez főként 64bites Windoes-os gépeken szokott problémákat okozni. Ha ez a helyzet, akkor próbálj meg egy 32 bites jdk is feltelepíteni.
    A stackoverflow-on pedig azt találtam, hogy a Netbeans a j2me esetében "hajlamos" "elfelejteni" a platformra vonatkozó konfigurációkat. Ezt ellenőrizni kell a Project Properties -> Platform and set the Platform Type and Emulator to your JavaME platform elérés alatt.

    Én azt csinálnám a helyedben - ha tényleg kitartóan szeretnél j2me alkalmazásokat fejleszteni (bár ma már én is az Androidot ajánlom inkább), hogy szedj le mindent (jdk, netbeans, j2me sdk, stb.) és telepíts mindent fel újra sorrendben: jdk, j2me sdk, és végül netbeans. Mindegyikből a legfrissebb kiadást.
    Talán ez segít. Nem tudom pontosan, hogy neked miért akad, mert én emlékszem, anno nekem simán ment minden, mivel én is elég sokat foglalkoztam j2me-vel, a fenti felépítésben.
    Mutasd a teljes hozzászólást!
  • Jó. Egy lépéssel tovább jutottunk mert már létre tudtam hozni egy MIDlet-et. Csakhogy amikor beinportálom a javax.microedition.midlet.*; -ot akkor ezt a hibaüzenetet adja ki:
    Unable to find package java.lang in classpath or bootclasspath
    És most nem tudom hogy mit nem talál, vagy mit kéne találnia és azt a valamit én hogyan tudom a helyére rakni.
    Mutasd a teljes hozzászólást!
  • Az még nem elég, hogy a Netbeans-ben tudsz indítani egy új J2ME projectet. Szükséges a J2ME development kit-nek is települve lennie. Innen tölthető le.
    Javaslom, hogy elöszőr telepítsd fel, aztán indíts egy új projectet a Netbeans-ben, bár ha jól emlékszem, akkor maga a kit is tartalmaz egy butított Netbeans-t j2me fejlesztésekhez. De ezt nem szükséges használni, a fel van telepítve, akkor a saját Netbeans-ed is meg fogja találni.
    Mutasd a teljes hozzászólást!
  • Már pár éve foglalkozom a javával és most nekiláttam (volna) a mobil programozásnak is


    Van valami beteges vonzódásod a halott platformok iránt vagy találtál egy régi könyvet, amelyben a mobilprogramozás alatt még a J2ME-t értik? Ha a Java irányt szeretnéd követni, akkor javaslom az Android platformot, sokkal hamarabb lesz sikerélményed, és hasznos alkalmazás esetén sokkal több embert tudsz elérni, akár még némi bevételed is lehet.
    Mutasd a teljes hozzászólást!
  • Üdv.
    Már pár éve foglalkozom a javával és most nekiláttam (volna) a mobil programozásnak is, csakhogy közbejött valami:
    NetBeanst használok és ezzel próbáltam meg a
    New project/Java ME/Mobil Application kiválasztásával egy kis programot kreálni. A következő hibaüzenetet dobta ki:
    "No J2ME compatible platform is installed in the IDE. You need to have at least one J2ME compatible platform installed in the IDE."
    Nem tudok angolul de azt tippelem hogy nem kompatibilis a J2ME az én NetBeansemmel. De én a legújabb (7.4-es) verziót töltöttem le amihez tartozott Java ME (meg minden más is). Légy szíves segítsetek hogy mit és honnan töltsek le hogy működjön.
    Előre is kösz.
    Mutasd a teljes hozzászólást!
abcd