PHP mail küldés localhostról
2013-03-14T13:13:33+01:00
2013-03-15T20:29:53+01:00
2022-07-19T03:52:12+02:00
  • Miért nem használod az internetszolgáltatód smtp szerverét? Tömeges email küldésre persze alkalmatlan, de tesztelni jó lehet. Nálam pl. csak két idevonatkozó sor van a php.ini-ben, és megy az email küldés localhost-ról is.

    Ez lenne az két sor:
    SMTP = smtp.upcmail.hu
    smtp_port = 25

    Ha más szolgáltatód van, mások a beállítások, de biztos meg lehet oldani, hogy menjen.
    Mutasd a teljes hozzászólást!
  • Mutasd a teljes hozzászólást!
  • Az engedélyezve van már régtől :) de már ezt is ellenőriztem
    Mutasd a teljes hozzászólást!
  • Pedig be van kapcsolva.
    Mutasd a teljes hozzászólást!
    Csatolt állomány
  • Valahol egyszer azt olvastam, hogy a gmail-es fiókban is engedélyezni kell a Beállítások alatt az smtp-t.
    Mutasd a teljes hozzászólást!
  • Helo,

    Leírtad hogy : "13/03/14 13:02:27 : SSL is not available on this server."

    Tehát akkor mégsincs bekapcsolva ezek szerint...
    Mutasd a teljes hozzászólást!
  • Sziasztok,

    Tudom, hogy sok téma foglalkozik a php mail küldéssel, de sajnos egyikben sem találtam megfelelő megoldást.

    A lényeg, hogy windows 7 alatt localhostról szeretnék e-mailt küldeni php-val, mert macera mindig szerverre másolgatni és onnan tesztelni. SMTPnek a gmail-es fiókomat szeretném használni.

    Letöltöttem a sendmail.zip csomagot, kicsomagoltam a D:\wamp\sendmail mappába, a php.ini-ben bállítattam az útvonalat. A fő problémám a sendmail.ini beállítása. Sajnos sehogy nem akar menni :(


    smtp_server=smtp.gmail.com
    smtp_port=587
    smtp_ssl=tls
    default_domain=localhost
    auth_username=username@gmail.com
    auth_password=password


    Persze így nem küldi el:
    13/03/14 13:02:27 : SSL is not available on this server.

    Apache ssl_module bekapcsolva, PHP php_openssl, php_sockets szintén.

    Próbáltam így is:

    ...
    smtp_port=465
    smtp_ssl=ssl
    ...


    Viszont így a sendmail.exe 25%ra eszi a procim, amíg ki nem lövöm a taskot.

    Verziók, ha valakinek kellene:
    Apache Version : 2.2.17
    PHP Version : 5.3.4
    MySQL Version : 5.1.53

    Valakinek esetleg tippje javaslata? Minden tippet szívesen fogadok.

    Előre is köszönöm.

    Üdv, R.
    Mutasd a teljes hozzászólást!
Tetszett amit olvastál? Szeretnél a jövőben is értesülni a hasonló érdekességekről?
abcd