Monodevelop .NET 4.0
2012-07-12T15:03:01+02:00
2012-07-14T22:48:20+02:00
2022-07-19T05:12:59+02:00
  • Nemigen, inkább a libc verziód számít szerintem. A rendszerre destruktív következménye nem nagyon lehet, maximum a program maga nem fog működni.
    Mutasd a teljes hozzászólást!
  • Nem WPF-et használok.
    Egy form sincs csak kód van amelyben csak pár referenciát használok (Mysql.Data,System.Data.Core,System.IO stb..) A másik meg az hogy Debian 6.0.5-öt használok és ennek régebbi kernelje van mint mostanság szóval nem nagyon merek újabbat felrakni monodevelopból (Nem tudom járna e valami következménnyel)

    Ja és fel van telepítve a MYSQL szóval azzal nincs probléma viszont a többivel igen.
    Mutasd a teljes hozzászólást!
  • Mintha azt olvastam volna, hogy a WinForm-ot (binding nélkül) elég jól támogatja már.


    Énis így hallottam, azért nem mertem javasolni, mert személyes tapasztalatom nincs róla. Én MonoDeveloppal GTK#oztam, ha jól rémlik Icaza is GTK#ot javasolja Linuxra.


    A WPF lehetne igazi cross-platform megoldás, csak kell aki megcsinálja


    Csak nincs aki megcsinálja. A WPF jóval nagyobb falat mint a WinForms, ha jól emlékszem Icaza valami olyasmit mondott, hogyha fizet neki valaki egy <nememlékszemhány> fős csapatot 2-3 évre csak erre a feladatra, akkor majd implementálják


    nem tudom milyen szerzői jogi gondok adódhatnak (mit aknázott alá a MS)


    A core .NET FW az a
    Microsoft Community Promise
    alatt van, ami legálisan köti az MSt, és pl. az Oracle vs. Google per kapcsán valamelyik jogi fejes az MStől közölte is, hogy ők nem tudnák a C#al megcsinálni azt amit az Oracle a Javaval. Ezért merti Sony is erre építeni a PlayStation Suitet.


    A cuccok, amik a core framewörkre épülnek, a WinFormstól a WPFen, XNAn át az ASP.NETig, már perelhetők lennének, de a .NET 10 éves fennálása óta tudtommal semmi hozzá köthetőt se támadott meg jogilag az MS, pedig használják jópár helyen.
    Nagyon kevéssé valószínű, hogy majd pont most mikor az MS is elkezdte evangelizálni a nyílt forrást fog jogi eszközökhöz folyamodni. Szóval tuti nem ez a probléma.


    Ahogy olvastam léteznek működő, éles ASP.NET alkalmazások is Mono-ban, és mivel a Razor/MVC nyilt forrású lett (ahogy olvastam), ez is lehet hogy megy már, vagy fog menni.


    Ja, tuti fog segíteni a Monos ASP.NETen a forrás megnyítása, Icaza már toborozott hozzá.
    Mutasd a teljes hozzászólást!
  • "A WPF pl. egyáltalán nem cross-platform semmilyen mélységben."

    Mintha azt olvastam volna, hogy a WinForm-ot (binding nélkül) elég jól támogatja már.

    A WPF lehetne igazi cross-platform megoldás, csak kell aki megcsinálja és nem tudom milyen szerzői jogi gondok adódhatnak (mit aknázott alá a MS).

    Ahogy olvastam léteznek működő, éles ASP.NET alkalmazások is Mono-ban, és mivel a Razor/MVC nyilt forrású lett (ahogy olvastam), ez is lehet hogy megy már, vagy fog menni.
    Mutasd a teljes hozzászólást!
  • Milyen verziójú mono ? Milyen verziójú monodevelop ? Mi adta az üzenetet ? Az IDE ? A C# fordító ? Mi az üzenet pontos szövege ?
    Mutasd a teljes hozzászólást!
  • Szóval valahogy nem lehetne telepíteni a NET 4.0-et hozzá hogy ne kelljen újra kezdenem NET 3-ban?


    Nagyon keveset dolgoztam MonoDeveloppal, de gyakorlatilag kizárt, hogy a verziószám a probléma.

    A legújabb Mono már a core .NET FW 4.5 beta verziójának legtöbb featurejét is támogatja. Van 1-2 dolog amit még 4.0-ból sem implementáltak, de ezek jellemzően olyanok amiket senki sem használ, nagyon kicsi a valószínűsége, hogy te éppen ilyenbe futottál bele.


    Ha a legújabb Monot szedted le, inkább arra gondolnék, hogy WPFet, vagy valami más cuccot használsz amit egyszerűen nem támogat. A WPF pl. egyáltalán nem cross-platform semmilyen mélységben.

    Ha windowson és linuxon is ugyanazt a UIt szeretnéd, talán GTK#al jársz a legjobban.
    Mutasd a teljes hozzászólást!
  • egyik mondatom nem volt érthető szóval :): találtam megoldást de az nekem nem működött...
    Mutasd a teljes hozzászólást!
  • Hali!
    Elkezdtem egy alkalmazást írni még Windowson de űrlapok nélkül. Áttértem linxura amikor fordítottam MonoDevelop-al akkor azt írta hogy nincs telepítve a NET 4.0 megoldást ami működik nem találtam!
    Szóval valahogy nem lehetne telepíteni a NET 4.0-et hozzá hogy ne kelljen újra kezdenem NET 3-ban?
    Mutasd a teljes hozzászólást!
Tetszett amit olvastál? Szeretnél a jövőben is értesülni a hasonló érdekességekről?
abcd