Firebird 2.5 aliasok nem működnek Win7 64bit
2012-06-18T18:45:11+02:00
2012-06-19T12:41:35+02:00
2022-07-19T05:12:39+02:00
  • Meg is oldotta a gondot, köszi a tippet!
    Mutasd a teljes hozzászólást!
  • Valószínűleg igazad lesz a jogosultságot illetően, mivel voltam olyan "nagyokos" és a /Program Files/Firebird/ mappába telepítettem.
    Azon filózok, hogy az aliases.conf fájl helyét kellene valahogy megváltoztatni, pl. a wamp/fdb/aliases.conf-ra, így talán nem lenne ilyen gondja.
    Mivel új vagyok a témában nem tudom, hogy egyáltalán lehet-e ilyet, és ha lehet akkor hogy...

    Szerintem a következő fog történni: Reinstall c:/fdb/ és meglátjuk... Köszi a tippet!
    Mutasd a teljes hozzászólást!
  • Jelenleg is Win7/64 alatt csatlakozom aliassal, ez nem okoz problémát.

    Valószínűnek tartok valamilyen jogosultsági gondot.
    Ha az alias textfilet nem tudja megnyitni valamiért, akkor (mivel nem kötelező elem) kihagyja és kész.

    Nézd meg, hogy a config file érvényre jut-e. (pl. tempdirectory-t átírod és megnézed, hogy keletkeznek-e ott filek vagy a RemoteServicePort-ot és megnézed hogy melyik porton tudsz kapcsolódni)

    [Talán ez az ötlet elindít egy úton ]
    Mutasd a teljes hozzászólást!
  • Sziasztok!

    Van valakinek valami ötlete, hogy Windows 7 Professional (64bit) alatt miért nem akarja a Firebird 2.5 "felismerni" az Alias-okat?(aliases.conf). WAMP-al használom és abszolút eléréssel működik minden, de alias-al már nem.

    Példa alias:
    szotar=c:\wamp\fdb\SZOTAR.FDB

    Ha ibase_connect-nél így adom meg a HOST-ot akkor tökéletes:
    'localhost:c:\wamp\fdb\szotar.fdb'

    Így meg semmi:
    'localhost:szotar'

    Windows XP alatt(32bit, VirtualBox-on) múltkor ugyan így feltelepítettem és semmi problémája nem volt az alias beállításokkal.

    Előre is köszönöm mindenkinek a segítséget!
    Mutasd a teljes hozzászólást!
Tetszett amit olvastál? Szeretnél a jövőben is értesülni a hasonló érdekességekről?
abcd