Keresőbotok nem látják az oldalam
2011-08-22T18:08:18+02:00
2011-08-23T18:08:34+02:00
2022-07-24T11:56:21+02:00
  • És igen, valóban.
    a nyelvek miatt van ellenőrzés az oldalon, és ott már session nyelvvel dolgozik.
    most látom csak, hogy nem tudástárba hanem társalgóba ment sajnos a téma, így nem tudom, kapsz-e pontot.
    mindenesetre nagyon köszönöm a megoldást, és mindenkinek a hozzászólásokat!
    Mutasd a teljes hozzászólást!
  • Az oka valahol a kódban van: ha nem kapja meg a session id-t, akkor újratölti az oldalt.

    Mivel a validátor (és gondolom a robotok sem) tárolnak el sütiket, így mindig frissen süti és session id nélkül hívja meg az oldalt, aminek a válasza az, hogy irányítsd át az oldalt (Location: ...) és állítsd be a sütit (Set-Cookie: ...) - de mivel a sütit nem állítja, csak követi a Location-t, így végtelen ciklusba kerül - majd 7 próbálkozás után leáll.
    Mutasd a teljes hozzászólást!
  • Érdekes, firefoxxal nem kapok semmit, csak ha a www.jobxway.com -ot hívom be, akkor 301-et, de ez normális.
    Mutasd a teljes hozzászólást!
  • jobxway.com
    Mutasd a teljes hozzászólást!
  • Add az oldal címét, rápillantanék. Lehet csak hibás szerver-beállítás, lehet valós átirányítás és még sok minden.
    Mutasd a teljes hozzászólást!
  • megnéztem ezzel a header-t, és ez a válasz:
    Server Response:
    HTTP/1.1 302 Moved Temporarily Date: Tue, 23 Aug 2011 05:16:06 GMT Server: Apache/1.3.41 (Unix) mod_fastcgi/2.4.2 PHP/5.2.10 mod_psoft_traffic/0.2 mod_ssl/2.8.31 OpenSSL/0.9.7a mod_macro/1.1.2 X-Powered-By: PHP/5.2.10 Set-Cookie: PHPSESSID=ikad2sftrndrdoh1hkocl2ro90; path=/ Expires: Thu, 19 Nov 1981 08:52:00 GMT Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0 Pragma: no-cache

    Mutasd a teljes hozzászólást!
  • Én a helyedben megnézném Firebuggal, hogy mit kapsz a headerben amikor behívod az oldalt.

    Ebből úgy tűnik, hogy valamiért egy 302 Temporarily Moved üzenetet kapsz.
    Ez lehet a htaccess miatt, de phpban is kiadható a header() függvénnyel.
    Mutasd a teljes hozzászólást!
  • Sziasztok!
    a problémám az, hogy van egy oldalam, amit semmilyen keresőbot nem lát, amiket ráengedtem(spider,w3 validator).
    ez egy wordpress alapú weboldal.van a tárhelyen egy hasonlóan wp-alapú oldal ugyanilyen beállításokkal, azt viszont látja...
    az iwebtool spider-je azt írja:
    Unable to view website. Please re-check address.
    a hiba amivel visszatér a validator:
    302 Moved Temporarily
    htaccess fájl nincs(legalábbis nem látható), próbálkoztam létrehozni egyet, feltöltöttem, semmi változás.
    kérlek bombázzatok ötletekkel mi lehet a probléma!
    köszönök előre is minden segítséget!
    Mutasd a teljes hozzászólást!
abcd