A Microsoft a hét közepén kiadta a Ruby nyelv .NET platform feletti nyílt forrású implementációjának első stabil változatát. A frissen megjelent IronRuby 1.0 az eredeti Ruby nyelv 1.8.6-os verziójával kompatibilis, ami azt jelenti, hogy némi elmaradást mutat az eredetihez képest, amely már az 1.9.1-es verziónál tart.

Az IronRuby futtatásához a .NET 2.0 Service Pack 1 vagy újabb verziója szükséges, ugyanis csak ez tartalmazza a Ruby működéséhez elengedhetetlen dinamikus nyelvi támogatást. Ugyanakkor a .NET 4.0-ra az IronRuby egy fejlett változata is letölthető, amely az új verzióban bemutatkozott plusz nyelvi funkciók kihasználását is lehetővé teszi.

A nyílt forrású IronRuby 1.0 a Microsoft CodePlex oldaláról tölthető le.