Excel rugalmas cellahivatkozás készítése

Ez a téma lezárásra került a moderátor által. A lezárás oka: Semmi köze a programozáshoz/fejlesztéshez, így keresnivalója sincs itt → PCForum.hu-ra való. A megfelelő kategória-besorolásra – is – ügyelj a jövőben.
Excel rugalmas cellahivatkozás készítése
2021-02-01T13:27:35+01:00
2021-02-01T14:47:01+01:00
2022-10-15T21:25:25+02:00
Yoindulat
Sziasztok!

Olyan problémára keresek megoldást, hogy van egy összesítő táblázatom, ami több, adatot tartalmazó táblázatból szedi az adatait.
Eddig sima ügy, csakhogy különböző nagyságú táblázatokról van szó, amikben szerencsére a sorok száma azonos, csak az oszlopok száma eltérő (ráadásul, csak hogy kerek legyen, ezek a jövőben várhatóan változni is fognak). Hogyan tudom megoldani, hogy teszem azt az "Össz fogyás" feliratú oszlopig terjedő táblára hivatkozzon a vkeres függvényem?
Amire eddig jutottam:

=CÍM(3;HOL.VAN("Össz fogyás";'táblázat1'!$3:$3);1;;)
Ez gyönyörű szépen visszaadja a vonatkozó cellára hivatkozást, viszont nem tudom, hogy tudnám képletbe varázsolni.

=VKERES(B$1;'táblázat1'!$F$3:$NV$3;SOR(F12)-1)
lenne az elvárt érték.
A fenti cím függvény létrehozza az $nv$3 hivatkozást, de ezt fentibe nem tudom, hogy hogyan kellene beilleszteni.

=VKERES(B$1;'táblázat1'!$F$3:CÍM(3;HOL.VAN("Össz fogyás";'táblázat1'!$3:$3);1;;);SOR(F12)-1)
Azt mondja, hogy hibás a képlet. Milyen függvény vagy összefűzés a megoldás, ami elkerülte a figyelmemet? Az összefűz fgv csak szöveget hoz létre, nem akarja utána a képletet számolni.
Végső soron meg tudom írni makróval is, csak a cégnél már lassan kiutálnak, mert minden táblázatomhoz engedélyezni kell a makrókat. :)

Előre is 1000 köszi a válaszért!
Mutasd a teljes hozzászólást!
Szia! ...ismét

Az előbb nem tudtam rendesen figyelni - zavaró környezeti hatások miatt :) - és elkapkodtam a választ. Bocs.
Ez lesz a megoldás:
=FKERES(keresési_érték;INDIREKT("keresési_tartomány:bal_felső_celllája:"&CÍM(sor;HOL.VAN(...)));3;IGAZ)
például az...
=FKERES(A1;INDIREKT("C3:"&CÍM(10;5));3;IGAZ)

Az "A1" cella tartalmát keresi meg a ...
"C3:F10" tartomány első oszlopában, azaz a C3:C10 tartományban és visszaadja a
"C3:F10" tartomány 3. oszlopában - tehát az "E" oszlopban - és az előbb megtalált érték sorában található cella értékét.

üdvözlettel
verax
Mutasd a teljes hozzászólást!

  • Szia Yoindulat!

    Az ilyen kérdéseket elég könnyű a HOL.VAN() és INDEX() párossal megoldani.
    HOL.VAN() függvénnyel megkeresed az Össz fogyás oszlop számát, amit az INDEX() függvénybe illesztesz.

    =INDEX(táblázat1;éppen_aktuális_sor, HOL.VAN("Össz fogyás";táblázat1_fejléce;0))

    üdvözlettel
    verax
    Mutasd a teljes hozzászólást!
  • Szia! ...ismét

    Az előbb nem tudtam rendesen figyelni - zavaró környezeti hatások miatt :) - és elkapkodtam a választ. Bocs.
    Ez lesz a megoldás:
    =FKERES(keresési_érték;INDIREKT("keresési_tartomány:bal_felső_celllája:"&CÍM(sor;HOL.VAN(...)));3;IGAZ)
    például az...
    =FKERES(A1;INDIREKT("C3:"&CÍM(10;5));3;IGAZ)

    Az "A1" cella tartalmát keresi meg a ...
    "C3:F10" tartomány első oszlopában, azaz a C3:C10 tartományban és visszaadja a
    "C3:F10" tartomány 3. oszlopában - tehát az "E" oszlopban - és az előbb megtalált érték sorában található cella értékét.

    üdvözlettel
    verax
    Mutasd a teljes hozzászólást!
Ez a téma lezárásra került a moderátor által. A lezárás oka: Semmi köze a programozáshoz/fejlesztéshez, így keresnivalója sincs itt → PCForum.hu-ra való. A megfelelő kategória-besorolásra – is – ügyelj a jövőben.
Tetszett amit olvastál? Szeretnél a jövőben is értesülni a hasonló érdekességekről?
abcd