Excel automatikus szakaszolás, több cella visszaadása

Excel automatikus szakaszolás, több cella visszaadása
2019-08-01T08:04:17+02:00
2019-08-02T12:06:55+02:00
2022-10-15T21:36:02+02:00
Benefi Ádám
Sziasztok,

szeretnék egy nagyon sok sorból álló oszlopot szakaszolni/több értéket visszakapni belőle.

Részlet:

******************************************
Date        : 07/16/2019
Time        : 06:42:33
Type        : Warning
Source      : acvpnui
Description : Function: CVerifyExtKeyUsage::Verify

******************************************
Date        : 07/16/2019
Time        : 06:42:33
Type        : Error
Source      : acvpnui
Description : Function: COpenSSLCertUtils::VerifyExtKeyUsage

******************************************
.
.
.


Ezek a sorok mint látható sok csillaggal vannak elválasztva. A Description-ben lévő dolgokat sikeresen kiszűrtem képlettel, de a dátumokat és időpontokat nem tudom kigyűjteni hozzá.

Van valakinek ötlete, hogy lehetne ezt megoldani? Pl. ha a Descriptionben XX áll, akkor a hozzá tartozó értékeket (Date, Type, stb.) is lássam valahogy.

Köszi előre is!
Mutasd a teljes hozzászólást!

  • Hali!

    Mutasd – VBA-forráskóddal –, hogy eddig mivel, hogyan próbálkoztál, meddig jutottál el, mi nem megy, miben/hol akadtál el!

    Mutasd a teljes hozzászólást!
  • Hali,

    eddig csak úgy sikerült megoldanom, hogy nem kigyűjtöttem a kívánt szakaszokat, hanem odaugrottam egy makrózott gombbal (első, utolsó, következő és előző gombok) mindig ahhoz a részhez, ami érdekelt. De kb 100e sorom van, és jobb lenne a releváns adatokat egymás alatt látni.

    -képlettel szűrtem rá a Description részre, és a releváns adatok melletti cellákban megjelenik egy "1"-es;
    -ezen cellák sorszámait kihasználva tudtam gombokat létrehozni, amik mindig az adott (első, utolsó vagy pl következő..) sorra ugranak, ahol egyest találnak.

    de csatolok egy képet, hogy mi is lenne a célom.

    Ezekkel operáltam eddig:

    'ugrás a következő releváns bejegyzésre

    Sub koviKatt()
    Range("F1").Value = Range("F1").Value + 1
    Dim a As String
    Dim b As String
    Dim c As Range
    a = Range("c1").Value
    b = Range("d1").Value
    Set c = Range(a + b)

    c.Select
    End Sub

    'ugrás az előző releváns bejegyzésre

    Sub elozoKatt()

    Range("F1").Value = Range("F1").Value - 1

    Dim a As String
    Dim b As String
    Dim c As Range
    a = Range("c1").Value
    b = Range("d1").Value
    Set c = Range(a + b)

    c.Select

    End Sub

    'ugrás az utolsó releváns bejegyzésre

    Sub utolsoKatt()

    Range("F1").Value = Range("M1").Value

    Dim oszlop As String
    Dim oszlop_ertek As String
    Dim vege As Range
    oszlop = "A"
    oszlop_ertek = Range("P1").Value
    Set vege = Range(oszlop + oszlop_ertek)

    vege.Select

    End Sub

    Sub elsoKatt()
    Range("F1").Value = 1

    Dim oszlop2 As String
    Dim oszlop_ertek2 As String
    Dim vege2 As Range
    oszlop2 = "A"
    oszlop_ertek2 = Range("L1").Value
    Set vege2 = Range(oszlop2 + oszlop_ertek2)

    vege2.Select

    End Sub
    Mutasd a teljes hozzászólást!
    Csatolt állomány
  • Ha jól látom, ugyanannyi sorból állnak a blokkok. Ha mégsem, akkor sincs gáz. Beírod a B oszlopba, hogy =HA(BAL(A1;4)="DATE";1;0)
    C oszlopba: =HA(B1=1;A1;"")
    D oszlopba: =HA(B1=1;A2;"")
    E oszlopba: =HA(B1=1;A3;"")
    stb.
    Így egy sorban lesznek a blokkjaid. Kimásolod, rendezed, és kész a listád belőle.
    Mutasd a teljes hozzászólást!
Tetszett amit olvastál? Szeretnél a jövőben is értesülni a hasonló érdekességekről?
abcd