INDIREKT fvhiv átalakítása egyszerű hivatkozássá VBA-ban

INDIREKT fvhiv átalakítása egyszerű hivatkozássá VBA-ban
2019-06-20T11:49:48+02:00
2019-06-20T15:14:49+02:00
2022-12-06T00:55:36+01:00
1Sopi
Excelben készítettem INDIREKT függvényt ami teljesen jól működik.
(B8: másik munkalap neve)
=HAHIBA(FKERES("Összesen";INDIREKT("'"&$B8&"'!B:AA";IGAZ);HOL.VAN(C$6;INDIREKT("'"&$B8&"'!3:3";IGAZ);0)-1;HAMIS);"")

Ez egy konkrét munkalap cellájának tartalmára mutat. (költségvetés összesítőnek használom, több van egymás alatt)
Azt szeretném leprogramozni VBA-ban, hogy a fenti képlet ne legyen "INDIREKT"-es, ugyanis ha törlök bizonyos segéd sor/oszlopokat a hivatkozott munkalapról, akkor nem fogja lekövetni cellára való hivatkozás (ami persze érthető is).

Van "INDIREKT" mentesítésre valami egyszerű menet, vagy minden egyes excel cellafüggvényemet (fenti képlet amiből egymás alatt sok van) vizsgálnom kell és kikerestetni az adott munkalap cellát valahogy?
Mutasd a teljes hozzászólást!
Mindent lehet.

1) KÉPLETSZÖVEG fv-nyel elmented szövegnek
2) Következő csellába összefűzöd egy '-fal az elejére (="'"&C1

3)Átcseréled, amit tudsz az angol nyelvű VBA-s nevére (Pl HAHIBA(FKERES( helyett IFERROR(VLOOKUP(
3) Az INDIREKT(-t semmire cseréled
4)
;-t ,-re cseréled stb.
" helyet ""
stb
5) ha jó a képlet makróval kimásolod a cella tartalmát az első ' kivételével, Elé elé és utána raksz " jelet.
(Kiveszed z értékét egy stringbe strValami=cells(i,j).value)
Az ActiveCell.formula képletel berakod mellé, és láss csodát!
Mutasd a teljes hozzászólást!

Tetszett amit olvastál? Szeretnél a jövőben is értesülni a hasonló érdekességekről?
abcd