Excel részlet keresés

Excel részlet keresés
2018-07-27T12:41:26+02:00
2018-07-27T21:16:53+02:00
2022-10-15T21:41:11+02:00
weryas
Sziasztok!

Egy kicsit összetett a kérdésem.

Adott egy nagy adatbázis. Ezt szeretném, hogy amely szám tartalmazza  a pl.: 11123567-et szövegben írja ki hogy alma (a szám 22 karakteres és az első 8 karakter szükséges. Ha pedig 11123568 szöveg legyen körte.  Minden más esetben legyen cement szöveg.
Mivel az adatbázis "A" (oszlop) tartalmaz olyan sorokat is melyek betűket is tartalmaz, akkor ezeknél a soroknál legyen üres cella.

Lehet, hogy túl bonyolultan írtam :(

Köszönöm!
Mutasd a teljes hozzászólást!
Csatolt állomány
Azért voltam kevésbé segítőkész, mert csak idecsaptad a feladatot, de semmi egyebet (a próbálkozásodat csak később mellékelted)! Erre legközelebb figyelj!

Szóval a kérdésedet én úgy értelmezem, hogy tartalmaznia kell (bárhol, tehát nem feltétlenül az elején) a 2 számból valamelyiket.
Ez esetben:

=HA(SZÁM(SZÖVEG.KERES("11123567";A1));"alma";HA(SZÁM(SZÖVEG.KERES("11123568";A1));"körte";"cement"))
Angol excel esetén: IF, ISNUMBER, SEARCH

Szerk:
Újra átnézve a fenti megoldás nem felel meg az utolsó feltételednek, miszerint, ha nem szám, akkor üresnek kell lennie.

A módosított formula:

=HA(SZÁM(A1);HA(SZÁM(SZÖVEG.KERES("11123567";A1));"alma";HA(SZÁM(SZÖVEG.KERES("11123568";A1));"körte";"cement"));"")
Mutasd a teljes hozzászólást!

Tetszett amit olvastál? Szeretnél a jövőben is értesülni a hasonló érdekességekről?
abcd