Excel legördülő lista

Excel legördülő lista
2018-06-07T13:24:13+02:00
2018-06-08T14:55:56+02:00
2022-10-15T21:36:25+02:00
M1k1
Sziasztok.

Excelben csináltam egy legördülő listát az A1 cellához, így néz ki a macro:

Option Explicit Private Sub Workbook_Open() With Munka1.ComboBox1 .AddItem "0" .AddItem "1" .AddItem "2" .AddItem "3" .AddItem "4" .AddItem "5" .AddItem "6" .AddItem "7" .AddItem "8" .AddItem "9" .AddItem "10" .AddItem "11" .AddItem "12" .AddItem "13" .AddItem "14" .AddItem "15" .AddItem "16" .AddItem "17" .AddItem "18" .AddItem "19" .AddItem "20" .AddItem "21" .AddItem "22" .AddItem "23" .AddItem "24" .AddItem "25" .AddItem "26" .AddItem "27" .AddItem "28" .AddItem "29" .AddItem "30"
End With End Sub
A B1 cellában van egy képlet:

=HA(A1<1;"Nincs kész!";B2)
Az a probléma, hogy ha A1<1 IGAZ, akkor is a B2 értékét írja be a cellába. Mintha a macro által beírt értékek nem is számok lennének. Tudna valaki segíteni?
Mutasd a teljes hozzászólást!
Írd így a képletet:

=HA(A1+0 < 1; "Nincs kész!"; B2)
Mutasd a teljes hozzászólást!

Tetszett amit olvastál? Szeretnél a jövőben is értesülni a hasonló érdekességekről?
abcd