Like gomb megjelenítési probléma explorerben

Like gomb megjelenítési probléma explorerben
2015-02-11T07:50:55+01:00
2015-02-15T07:11:05+01:00
2022-12-02T04:30:43+01:00
404
Sziasztok!
Nekem az internet explorer 11-el akadt gondom a facebook like és megosztás gombal. A többi böngészőben megjelenik(firefox,Opera) csak az explorerben nem, akármit csinálok vele.
Így néz ki az oldal erre vonatkozó része:
<!doctype html>
<html prefix="fb: http://www.facebook.com/2008/fbml og: Open Graph protocol lang="hu-HU">
...
...
<meta property="og:locale" content="hu_HU" />
<meta property="og:type" content="website" />
<meta property="og:url" content="<?php echo $oldal; ?>" />
<meta property="og:title" content="<?php echo $row['cim']; ?>" />
<meta property="og:description" content="<?php echo $alszov; ?>" />
<meta property="og:image:type" content="image/jpeg" />
<meta property="og:image:width" content="550" />
<meta property="og:image:height" content="413" />
<meta property="og:image" content="<?php echo 'http://...' . $row['kep1']; ?>" />
<link rel="canonical" href="<?php echo $oldal; ?>" />
...
...
<iframe src="//www.facebook.com/plugins/like.php?href=<?php echo rawurlencode('http://' . $_SERVER['HTTP_HOST'] . $_SERVER['REQUEST_URI']); ?>&amp;width=200&amp;layout=button_count&amp;action=like&amp;show_faces=true&amp;share=true&amp;height=21" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:200px; height:21px;" allowTransparency="true"></iframe>

Mi lehet a hiba?

Mutasd a teljes hozzászólást!
És ha megnéznéd ezt az OLDALT, majd miután beállítod a kívánt adatokat rákattintasz a Get Code gombra, a kapott kódot (HTML5 és IFRAME) és beillesztenéd ezeket az oldaladra?...
Mert nekem mind a kettő megjelenik IE-11 alatt is...
Megj: Ha így sem megy, keress PRIVÁT...
Mutasd a teljes hozzászólást!
Csatolt állomány

  • Próbaképp nézd meg a KÖVETKEZŐ OLDALT, hogy a jobb felső sarokban megjelenik-e a megosztás-gomb (nekem igen IE-11 esetén)...
    Ha neked is nézd meg a forrást is hogyan van megírva az FB-kód...
    Mutasd a teljes hozzászólást!
  • Üdv, szabofe által linkelt oldalon nálam se jelenik meg a megosztás gomb se ie11 se chrome alatt. A konzolban viszont volt egy üzenet (FB:login_button failed to re-size in 45s). Ezzel kapcsolatban nézd meg ezt vagy az itteni válaszokat, hátha segít.
    Mutasd a teljes hozzászólást!
  • ... szabofe által linkelt oldalon nálam se jelenik meg...

    Akkor nekem egy WIN-7 / EXTRA IE-11 böngészőm lehet...
    Mutasd a teljes hozzászólást!
    Csatolt állomány
  • Nalam kb 20 masodperces kesessel jelent meg internet explorerbe.
    A Console tartalma:

    HTML1300: Navigation occurred.
    File: proghu_teszt.php
    HTML1524: Invalid HTML5 DOCTYPE. Consider using the interoperable form "<!DOCTYPE html>".
    File: proghu_teszt.php, Line: 1, Column: 1
    Invalid App Id: Must be a number or numeric string representing the application id.
    FB.getLoginStatus() called before calling FB.init().

    Nem tudom, hogy lenyeges-e az utolso sor. :D
    Mutasd a teljes hozzászólást!
  • Sajnos nekem sem jelenik meg a gomb a linkelt oldalon. 
    disy68 által linkelt oldalakon sem találtam rá megoldást.
    Érdekes módon a komment viszont megjelenik. Csak a like és a sahre gomb nem, meg a g+ és a twitter is.
    Néztem a hibakonzolt és ezt írja:

    CSI/tbsd_: 1 751,314 ms
    CSI/_tbnd: 1 753,364 ms
    Invalid App Id: Must be a number or numeric string representing the application id.
    FB.getLoginStatus() called before calling FB.init().

    Vagyis nem hiba csak figyelmeztetés.
    Mutasd a teljes hozzászólást!
  • Na ez nagyon fura!
    A következő kód működik firefoxban és operában:
    <a href="http://www.facebook.com/sharer/sharer.php?u=<?php echo urlencode('http://' . $_SERVER['HTTP_HOST'] . $_SERVER['REQUEST_URI']);?>" target="_blank">megosztás</a>

    az explorer az irja hogy a lap nem jeleníthető meg.

    Mi ez? Tiltja az explorer a facebook-ot? De ha belépek a facebook.com ra simán beenged.
    Mutasd a teljes hozzászólást!
  • Ez az összes kódom
    <meta property="og:image" content="http://family-team.emszinet.hu/proghutest/progtesztek1.jpg" /> //majd ez <div class="fb-share-button" data-href="http://family-team.emszinet.hu/proghutest/proghu_teszt.php" data-type="button_count" style="position:absolute;right:5px;top:1px;width:150px; height:22px;display:block;z-index:10000; /*background-color:pink;*/"></div> //a fájl végén ez <div id="fb-root"></div> <script type="text/javascript"> (function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = "//connect.facebook.net/hu_HU/all.js#xfbml=1"; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk')); </script>
    IE-11 megjelenés csatolva (ie alatt FB-be bejelentkezve) és nekem nincs HB-üzenet...
    Mutasd a teljes hozzászólást!
    Csatolt állomány
  • nekem mindenféle várakozás nélkül megjelenik
    Mutasd a teljes hozzászólást!
    Csatolt állomány
  • Sajnos a te kódoddal sem megy. Már kezdek arra gondolni hogy az én exploreremmel van a gond. Nincs valami biztonsági beállítása ami miatt ezt csinálja? Mert nézegettem a neten néhány oldalt és egyiken sem jelenik meg a megosztás gomb az explorerben. Más böngészőben viszont igen.
    Mutasd a teljes hozzászólást!
  • Próbaként nézd meg a SAJÁT KÉRDÉSED prog.hu-s oldalát, hogy a jobb oldalon a "Hírek / Videók" felirat fölött ott van-e a "Tetszik" FB-gomb (!!!úgy is, hogy belépsz az FB-be!!!)... -> Eredmény
    Ha az sincs, akkor az IE-dnek valamiért vagy nem 11-es a verziója, vagy valamit nagyon elállítottál benne...
    Mint írtam már, nekem WIN7 opr. alatt IE-11 van telepítéskori alapállapotban (csak az módosult ami a WIN-frissítésekkel módosul), én semmit nem állítottam rajta, mivel nem használom, csak ritkán TESZT-ellenőrzésre...
    ********************
    Esetleg próbáld eltávolítani(REVO-uninstaller) és újraindítás után újra telepíteni az IE11-et...
    ***************
    Megj: Remélhetőleg nem XP-d van...
    Mutasd a teljes hozzászólást!
  • Újratelepítettem az IE-t, meg az alapbeállítással is próbékoztam de semmi. Ugyanazt csinálja. Amugy Win7 van nálam is. Ugy tudom hogy XP-n ami futhat az IE9 maximum.
    Mutasd a teljes hozzászólást!
  • És ha megnéznéd ezt az OLDALT, majd miután beállítod a kívánt adatokat rákattintasz a Get Code gombra, a kapott kódot (HTML5 és IFRAME) és beillesztenéd ezeket az oldaladra?...
    Mert nekem mind a kettő megjelenik IE-11 alatt is...
    Megj: Ha így sem megy, keress PRIVÁT...
    Mutasd a teljes hozzászólást!
    Csatolt állomány
  • Talán telepítettél valamikor valamilyen reklámszűrő bővítményt az IE-hez amit nem befolyásol az hogy újratelepíted az IE-t, és emiatt nem jelenik meg a like gomb.
    Mutasd a teljes hozzászólást!
  • Innen vettem a kódot, csak a dinamikus oldal miatt a href-t kiegeszítettem php-vel. De már úgy vagyok vele hogy aki llájkolni akarja az nézze firefoxban, akinek megy explorerben az is, akinek nem az meg így járt. Remélhetőleg a Microsoft hamarosan javítja ezt a problémát, és nem kell tovább ilyesmivel görcsölni. 
    Úgy gonoltam szabofe kapja a pontot, mert a legtöbb időt ő szánta a kérdésemre, és végülis meglett válaszolva a kérdés, mert valószínüleg nálam működik más beállításokkal az IE.
    Köszönöm a segítséget mindekinek!
    Mutasd a teljes hozzászólást!
Tetszett amit olvastál? Szeretnél a jövőben is értesülni a hasonló érdekességekről?
abcd