Oszlop adatainak kitöltése Excelben

Oszlop adatainak kitöltése Excelben
2009-12-11T22:16:48+01:00
2009-12-12T21:11:07+01:00
2022-11-16T00:05:35+01:00
Omegared
Sziasztok!

Adott a következő problémám.

Minden 3. nap kapok egy csv fájlt amiben van 20000+ sornyi termék.
Ezt a fájlt kell módosítanom úgy, hogy kompatibilisek legyenek az adatok cégem rendszeréhez.

Van egy saját excel táblám amiben kategória nevekhez tartozó azonosító számok vannak.


A B 1.kategória 1222 2.kategória 1223
stb stb, kb 1200 sor.

A problémám az, hogy a kapott csv-ben csak a szöveges kategória nevek vannak pl:
X 2.kategória 1.kategória 2.kategória
stb stb, random módon kb 700 különféle.

Milyen módszerrel tudnám egy új oszlopba behelyettesíteni a kategória azonosítóját a listám alapján a kapott csv fájlban?

Segítségeteket előre köszönöm!

Üdv:
Omegared
Mutasd a teljes hozzászólást!
Jónak jó, de minek ilyen bonyulutan?

=FKERES(A1;kategóriák!A:B;2;0)
És kész.


-----------
Omegared:
Megnyitod a kategória neveket tartalmazó munkafüzetet
Megnyitod a feldolgozandó munkafüzetet
Beszúrsz egy új oszlopot az "X" után, (ha nem lenne ott üres)
Beírsz egy oslop címet
A "X" oszlop elején állva Ctrl+lefelenyíl (már ha végig fel van töltve)
Jobbra nyíl
Ctrl+Shift+ felfele nyíl (Kijelölöd az üres helyeket - meg sajnos a fejlécet))
Shift+Lefele (Fejléc kihagyás)
Elkezded írni (úgy hogy elettö nem kattintasz, lépsz sehova): =FKERES(X2;[Kategoriak.xls]KategoriakLap!A:B;2;0) Az elfogadás Ctrl+Enter
Szerkesztés > Másolás, Szerkesztés > Irányított beillesztés > Értéket (HA nem akarod, hogy mindig cellaváltoztatáskor 20.000 + fkerest csináljon)
Kitörölheted az "X" oszlopot, ha a kategória név nem kell.

Ha máshol kell a kategóriákat tartalmazó oszlop, akkor bárhova átrakhatod.

Átválthatsz a kategóriák munkafüzetre és bezárhatod....
----

Mindezt Eszközök > makró > új makró rögzítése menüpont alatt (egy új munkafüzetbe) lerögzítheted, és akkor lesz egy programod, ami megcsinálja.
Ami kb. lehet belőle (kis átírással):
2 workbooks.open 'Utána meg átírhatod: range("Y:Y").entirecolumn.insert veg=Activesheet.usedrange.rows.count range("Y2:Y"& veg)="=Vlookup(X2,[Kategoriak.xls]KategoriakLap!A:B,2,0)" range("Y2:Y"& veg).copy range("Y2:Y"& veg).pastespecial xlvalues
Mutasd a teljes hozzászólást!

  • Feltöltöttem egy Excel-fájlt IDE.

    kategóriák munkalap: felsorolod a kategóriákat, és mellé írod a saját ID-t.

    adatok munkalap: valamilyen kategórianevet beírsz, és bemásolod a képletet valamely mellette lévő oszlopba.

    Remélem, jó lesz.
    Mutasd a teljes hozzászólást!
  • Jónak jó, de minek ilyen bonyulutan?

    =FKERES(A1;kategóriák!A:B;2;0)
    És kész.


    -----------
    Omegared:
    Megnyitod a kategória neveket tartalmazó munkafüzetet
    Megnyitod a feldolgozandó munkafüzetet
    Beszúrsz egy új oszlopot az "X" után, (ha nem lenne ott üres)
    Beírsz egy oslop címet
    A "X" oszlop elején állva Ctrl+lefelenyíl (már ha végig fel van töltve)
    Jobbra nyíl
    Ctrl+Shift+ felfele nyíl (Kijelölöd az üres helyeket - meg sajnos a fejlécet))
    Shift+Lefele (Fejléc kihagyás)
    Elkezded írni (úgy hogy elettö nem kattintasz, lépsz sehova): =FKERES(X2;[Kategoriak.xls]KategoriakLap!A:B;2;0) Az elfogadás Ctrl+Enter
    Szerkesztés > Másolás, Szerkesztés > Irányított beillesztés > Értéket (HA nem akarod, hogy mindig cellaváltoztatáskor 20.000 + fkerest csináljon)
    Kitörölheted az "X" oszlopot, ha a kategória név nem kell.

    Ha máshol kell a kategóriákat tartalmazó oszlop, akkor bárhova átrakhatod.

    Átválthatsz a kategóriák munkafüzetre és bezárhatod....
    ----

    Mindezt Eszközök > makró > új makró rögzítése menüpont alatt (egy új munkafüzetbe) lerögzítheted, és akkor lesz egy programod, ami megcsinálja.
    Ami kb. lehet belőle (kis átírással):
    2 workbooks.open 'Utána meg átírhatod: range("Y:Y").entirecolumn.insert veg=Activesheet.usedrange.rows.count range("Y2:Y"& veg)="=Vlookup(X2,[Kategoriak.xls]KategoriakLap!A:B,2,0)" range("Y2:Y"& veg).copy range("Y2:Y"& veg).pastespecial xlvalues
    Mutasd a teljes hozzászólást!
  • Azért nem az fkeres-t használtam, mert az csak akkor múkodik, ha az adatok sorba rendezettek.
    Mutasd a teljes hozzászólást!
  • mert az csak akkor múkodik, ha az adatok sorba rendezettek.


    Ezt azért én nem mondanám. (Mert tudom, hogy nem így van.)

    Nézz utána a 4. argumentumnak, ami hasonló a Hol.van 3. argumentumához
    Mutasd a teljes hozzászólást!
  • Igaz, még nem figyeltem fel rá eddig.
    Mutasd a teljes hozzászólást!
Tetszett amit olvastál? Szeretnél a jövőben is értesülni a hasonló érdekességekről?
abcd